Errors when importing DDR -- InspectorPro 6

BrentBollmeier's Avatar

BrentBollmeier

30 Nov, 2016 08:13 PM

Hello,

I'm having some issues importing a couple of my DDRs into InspectorPro 6...

The error on the first file is "The file 'ErrorReport.txt' could not be found and is required to complete this operation."

The error on the second file is "The file '3_ACCOUNT.xml' could not be found and is required to complete this operation."

Canceling the errors out doesn't seem to lead to a successful import. Is there any advice that can be lent?

Thanks

BrentBollmeier

This discussion was closed! See this FAQ for more information:

  1. Errors after importing DDR

    Issue: InspectorPro may experience errors after importing a DDR, if the DDR was not located on the desktop during import. For example, certain reports, such as Dependencies, may show no results.

    Solution: Move the DDR to the desktop and try to import it again.

    See more..

Showing page 2 out of 2. View the first page

  1. 31 Posted by BrentBollmeier on 12 Dec, 2016 05:18 PM

    BrentBollmeier's Avatar

    Hi Vince,

    Just wanted to see if you had any progress… Is it possible that we’re running into a file encoding issue? I was trying to look at the text files in gVim and had to do some magic to remove a lot of “^@” characters.

    I think it probably also goes without saying that there are WAAAY too many things going on in one file…

    Thanks!

    Brent Bollmeier
    Bollmeier Crane & Lift
    618.477.8542

    Disclaimer: The information contained in this e-mail, and attached documents, may be confidential information. The information is intended only for use by the designated recipient. If you are not the intended recipient, any dissemination, distribution, copying, or other use of, or taking of any action in reliance on this e-mail is strictly prohibited. If you have received this email communication in error, please notify the sender immediately and delete the message from your system.

  2. 32 Posted by BrentBollmeier on 12 Dec, 2016 07:57 PM

    BrentBollmeier's Avatar

    Also, I just discovered one other potential issue…

    It seems a number of the linked files that get opened when I create the DDR have a blank space character before the period in their filenames. This doesn’t cause FileMaker any problems, but when I create the DDR it will ask me to locate these files. Could that be causing issues?

    From: Brent Bollmeier
    Sent: Monday, December 12, 2016 11:18 AM
    To: 'Beezwax Support' <[email blocked]>
    Subject: RE: Errors when importing DDR -- InspectorPro 6 [InspectorPro 5 & 6 #628]

    Hi Vince,

    Just wanted to see if you had any progress… Is it possible that we’re running into a file encoding issue? I was trying to look at the text files in gVim and had to do some magic to remove a lot of “^@” characters.

    I think it probably also goes without saying that there are WAAAY too many things going on in one file…

    Thanks!

    Brent Bollmeier
    Bollmeier Crane & Lift
    618.477.8542

    Disclaimer: The information contained in this e-mail, and attached documents, may be confidential information. The information is intended only for use by the designated recipient. If you are not the intended recipient, any dissemination, distribution, copying, or other use of, or taking of any action in reliance on this e-mail is strictly prohibited. If you have received this email communication in error, please notify the sender immediately and delete the message from your system.

  3. Support Staff 33 Posted by Vince Menanno on 12 Dec, 2016 08:10 PM

    Vince Menanno's Avatar

    Hi Brent,

    For sure if not all the files are included then it will be a problem but the files you sent me it worked fine.

    So there must be some issue with trying to resolve invalid characters on the windows side in the XML because on the mac it works fine.

    Vince

  4. 34 Posted by BrentBollmeier on 12 Dec, 2016 08:18 PM

    BrentBollmeier's Avatar

    Right – with each missing file I do go locate it when asked when generating the DDR.

  5. Support Staff 35 Posted by Vince Menanno on 12 Dec, 2016 08:20 PM

    Vince Menanno's Avatar

    Is that at the time you generate the DDR… if so then all you need todo is make sure you have all your files open with full access then you won’t be getting asked all the time.

    Vince

  6. 36 Posted by BrentBollmeier on 12 Dec, 2016 08:22 PM

    BrentBollmeier's Avatar

    It is… but the files that I mentioned before with the space before the period in the filename still get prompted. I’m going to see if I can resolve that issue on my side, because it’s not good form… if there’s ever a trim() or something done on it, it’ll cause issues.

  7. Support Staff 37 Posted by Vince Menanno on 12 Dec, 2016 08:27 PM

    Vince Menanno's Avatar

    Brent,

    Lets find a time maybe do this together - over a screen sharing session.

    Vince

  8. 38 Posted by BrentBollmeier on 13 Dec, 2016 05:46 PM

    BrentBollmeier's Avatar

    Hi Vince,

    I’m available anytime from 1pm-3pm Central today, or anytme Thursday.

    Thanks,

    Brent

  9. Support Staff 39 Posted by Vince Menanno on 13 Dec, 2016 11:15 PM

    Vince Menanno's Avatar

    Thursday might be hard for me.

    How about this Friday?

    Vince

  10. 40 Posted by BrentBollmeier on 13 Dec, 2016 11:18 PM

    BrentBollmeier's Avatar

    Friday would be fine.

    Get Outlook for Android<https://aka.ms/ghei36>

    ________________________________

  11. Support Staff 41 Posted by Vince Menanno on 13 Dec, 2016 11:23 PM

    Vince Menanno's Avatar

    what is your number

  12. 42 Posted by BrentBollmeier on 13 Dec, 2016 11:24 PM

    BrentBollmeier's Avatar

    I'll have to let you know tomorrow - I bounce between two offices, and I'm not sure yet where I'll be.

    Get Outlook for Android<https://aka.ms/ghei36>

    ________________________________

  13. 43 Posted by BrentBollmeier on 16 Dec, 2016 09:11 PM

    BrentBollmeier's Avatar

    Hi Vince,

    An update on the issue…

    I’m able to import a DDR into Inspector Pro… somewhat. If I create a DDL for everything except scripts and import it, it works fine until I get the attached “ErrorReport.txt” error. However, if I click OK and continue the script, it seems to still be working. (And now that I’m able to use it, I have to say that InspectorPro is a HUGE help to development.)

    If I create a DDR with only the Scripts, I still get the error about “3_ACCOUNT.xml” that is also attached.

    Thanks,

    Brent

  14. Support Staff 44 Posted by Vince Menanno on 16 Dec, 2016 10:15 PM

    Vince Menanno's Avatar

    Brent,

    Lets have a call at some point.

    So we can address this.

    Vince

  15. 45 Posted by BrentBollmeier on 19 Dec, 2016 06:16 PM

    BrentBollmeier's Avatar

    I think I may have made a breakthrough…

    While experimenting with the scripts in the file (all 988 of them… yikes….) I found something that seems to be causing the problem. With a subset of about 40 scripts, I found that removing the highlighted script and line eliminates the error and gives me a clean import into Inspector Pro. Since I’m still gaining familiarity with FM, I’m not sure what part of it is causing the problem, though I agree that it’s not the best practice to specify the print driver in something like this…

    Thanks,

    Brent

    [cid:[email blocked]]

  16. 46 Posted by BrentBollmeier on 19 Dec, 2016 08:14 PM

    BrentBollmeier's Avatar

    A little further information… after filtering for all scripts with the word “print”, I found a number of references to specific print queues or print drivers. Taking those out not only gives me XML that will import into InspectorPro, but also the XML file is about 5%-10% of what it is with those 10 or 15 scripts.

    Thanks,

    Brent

    From: Brent Bollmeier
    Sent: Monday, December 19, 2016 12:16 PM
    To: 'Beezwax Support' <[email blocked]>
    Subject: RE: Errors when importing DDR -- InspectorPro 6 [InspectorPro 5 & 6 #628]

    I think I may have made a breakthrough…

    While experimenting with the scripts in the file (all 988 of them… yikes….) I found something that seems to be causing the problem. With a subset of about 40 scripts, I found that removing the highlighted script and line eliminates the error and gives me a clean import into Inspector Pro. Since I’m still gaining familiarity with FM, I’m not sure what part of it is causing the problem, though I agree that it’s not the best practice to specify the print driver in something like this…

    Thanks,

    Brent

    [cid:[email blocked]]

  17. Support Staff 47 Posted by Vince Menanno on 19 Dec, 2016 09:15 PM

    Vince Menanno's Avatar

    Brent,

    You did it … I am still looking on my end to see why it parsed on the mac side and not on windows but you solved it.

    Did you remove the print steps or redo them with FM 15?

    And yes that is a bug that I have seen before.

    Vince

  18. 48 Posted by BrentBollmeier on 19 Dec, 2016 09:28 PM

    BrentBollmeier's Avatar

    At this point I simply took out the scripts. I need to see if they're even referenced before I do much fixing.

    Brent

    Get Outlook for Android<https://aka.ms/ghei36>

    ________________________________

  19. Support Staff 49 Posted by Vince Menanno on 19 Dec, 2016 11:37 PM

    Vince Menanno's Avatar

    Brent,

    I would be curious to see if you added them back in 15 if the bug would still be there.

    Vince

  20. 50 Posted by BrentBollmeier on 19 Dec, 2016 11:46 PM

    BrentBollmeier's Avatar

    I've been working in FM15.

    Get Outlook for Android<https://aka.ms/ghei36>

    ________________________________

  21. 51 Posted by BrentBollmeier on 19 Dec, 2016 11:47 PM

    BrentBollmeier's Avatar

    Sorry, I've been working in 14.

    Get Outlook for Android<https://aka.ms/ghei36>

    ________________________________

  22. Support Staff 52 Posted by Vince Menanno on 19 Dec, 2016 11:51 PM

    Vince Menanno's Avatar

    Ok so it seems like it is still a current bug in FM 15 … what version of Windows again.

    Thanks so much

  23. Support Staff 53 Posted by Vince Menanno on 19 Dec, 2016 11:52 PM

    Vince Menanno's Avatar

    Disregard what I just said… when you do get a chance to test on FM 15 let me know if that is fixed.

    I will see if I can replicate on my end.

    Vince

  24. BrentBollmeier closed this discussion on 29 Dec, 2016 03:55 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

08 Dec, 2019 05:57 PM
05 Dec, 2019 04:23 PM
20 Nov, 2019 06:16 PM
31 Oct, 2019 05:57 PM
02 Nov, 2018 06:31 PM